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 User Instructions for 
WEGO Log Software 

CAUTION: CAREFULLY READ INSTRUCTIONS BEFORE PROCEEDING. THE USER IS 
ASSUMED TO BE FAMILIAR WITH MICROSOFT WINDOWS AND PC OPERATION. 

OVERVIEW 
WEGO Log software runs under Microsoft 

Windows 98/ME/XP/Vista. This software allows WEGO 
users to download and display data logged by the unit 
and to setup certain data logging functions. WEGO Log 
version 6.0 supports all WEGO units with internal data 
logging including the new WEGO III and WEGO IV 
series.   

After WEGO Log is launched, the main screen 
appears blank. Data logged by the WEGO unit must be 
downloaded before it can be displayed, by using the 
Download Data From WEGO command on the 
Communications menu. Once data has been 
downloaded, it is automatically displayed on a chart 
recorder type screen. You can save this data by using 
the Save File command from the File menu. You can 
also display a previously saved data file by first using 
the Open File command on the File menu.  

A sample data file (Sample.log) for an actual 
road test is included in the program folder. 

PC REQUIREMENTS 
We recommend a laptop with Pentium processor 

and super VGA display (SVGA with 1024 x 768 pixel 
resolution) running Windows 98/ME/XP/Vista. Data 
chart display is graphics intensive and a high speed 
Pentium processor is recommended. Processors 
slower than 300 MHz will exhibit sluggish program 
loading and response. The PC must have a CDROM 
drive for program loading.  

WEGO Log includes print commands to print 
downloaded data. The program has been tested with 
Hewlett-Packard laser and inkjet printers and Epson 
inkjet printers. We recommend using a color inkjet 
printer. 

New WEGO III and WEGO IV 
The new WEGO III and WEGO IV units connect 

to your PC by means of a USB interface. A USB cable 
is supplied with the unit. The PC must have a free USB 
port. If you have an older PC without USB capability, 
you cannot use the unit.  

When launched for the first time, the program 
uses COM1 as the default port. In most cases, you will 
have configured the unit’s USB interface to use a 
different COM port, such as COM5. Use the Port Setup 
command on the Communications menu to select the 
correct COM port. The program will remember the new 
port setup.  

WEGO II 
Older WEGO II units have a female 9 pin D-sub 

connector that interfaces to an RS-232 serial port on 
the laptop PC. In most cases, you will need to use a 9 
pin male-to-female extension cable such as our P/N 
RS232-CBL-10 to reach the PC. Similar cables are 
available from Belkin (www.belkin.com) as P/N 
F2N209-06-T or Office Depot as P/N 825851. You can 
also find the same type of cable at most office and 
computer supply stores.  

Data transfer occurs at 56 kBaud. The high baud 
rate limits the maximum cable length and the use of an 
extension cable over 12 feet in length is not 
recommended. Due to the cable length limitation and 
the need for portable access, a laptop PC is 
recommended. The PC must have a free serial port 
(COM1-255) with a standard 9 pin male D-sub 
connector. If your laptop does not include a serial port, 
you can use a USB adapter. However, not all USB 
adapters will work correctly with the WEGO II. Most of 
the inexpensive USB adapters are intended for 
interfacing Palm Pilot type devices and do not support 
the high baud rate required by our unit.  

We sell and recommend a low cost USB adapter 
(P/N USBG-232) that has been tested with a wide 
range of system configurations. The USBG-232 
adapter comes with correct and updated driver files on 
CDROM. After installation the USBG-232 adapter will 
usually appear as COM5.  

USB INSTALLATION 
WEGO III and WEGO IV units require 

installation of USB interface drivers. If you have 
already installed the USB interface drivers, or you are 
only using an older WEGO II unit, you can skip this 
step. 
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The WEGO III and WEGO IV USB interface is 
based on the FTDI FT232R chip and VCP (virtual COM 
port) drivers that allow the units to emulate a standard 
Windows RS-232 COM port. Updated Windows 
drivers, installation instructions and troubleshooting 
tips are available on the FTDI website at 
www.ftdichip.com.  

You will require the Daytona Sensors CDROM 
for installation. For Windows 98 and ME, use the 
drivers in the VCP_Drivers_Win98ME folder on the 
CDROM. For Windows XP and Vista, use the drivers in 
the VCP_Drivers_Win2KXP folder. You can install 
directly from the CDROM or copy these files to a folder 
on your hard drive. 

The standard Windows installation process is 
used, as with other USB devices. If you have never 
installed a USB device, you can refer to the 
appropriate FTDI Windows Installation Guide (in the 
USB_Interface folder on the CDROM) for step-by-step 
details. Individual guides are provided for Windows 98, 
2000 (2K), and XP/Vista. The Windows 98 guide is 
also applicable to Windows ME. Refer to the table of 
contents in the appropriate guide for Installing FT232R 
Devices/Installing VCP Drivers.  

1. Insert the CDROM. Exit from the Daytona Sensors 
autorun menu if it appears.  

2. Connect the unit to the PC with the supplied USB 
cable.  

3. The Windows Found New Hardware Wizard will 
appear. Do not click on the option to connect to 
Windows Update.  

4. Click on the option to install from a specific 
location, click on the option to search for the best 
driver, and then browse to the VCP_Drivers folder 
on the CDROM. Disregard any warnings about 
drivers that have not passed Windows Logo 
testing.  

5. The wizard will complete installation of the USB 
serial converter (FTDI chip). This completes the 
first part of the installation. 

6. The wizard will reappear to install the COM port 
driver. Repeat steps 3-4 above. 

COM Port Configuration 
After completing the installation steps outlined 

above, you must configure the new COM port using 
Device Manager.  

1. Click Start, Settings, Control Panel, System, 
Hardware, and then Device Manager. Scroll down 
to Ports (COM and LPT).  

2. The unit will as appear as a USB Serial Port. Click 
on this new port. 

3. Click on the Port Settings tab. 

4. Click on Advanced. In most cases the wizard will 
have installed your new unit as COM4 or COM5. 
For optimum performance, you should change the 
BM Options Latency Timer to 2 msec as shown in 
Figure 1. 

5. Once you have configured a COM port number for 
your new unit, make sure that you use this same 
COM port selection in the WEGO Log software by 
using the Port Setup command from the 
Communications menu. 

Figure 1 – COM Port Configuration 

 
SOFTWARE INSTALLATION 

The software is supplied on CDROM media or in 
the form of a compressed file downloaded from our 
website. The installation process uses InstallShield. 
This industry standard installer is based the new 
Microsoft Windows Installer service that greatly 
reduces potential problems such as version conflicts 
and allows for application self-repair. Since Windows 
98 systems did not originally include the Windows 
Installer service, the required installer software is 
included in the distribution media.  

Before proceeding with installation, shutdown any 
other applications that may be running. For Windows 
Vista, you must disable the User Account Control 
(UAC) during installation. If you are not familiar with the 
UAC, please refer to the Vista UAC Tech Note on our 
website's Tech FAQ for details. 

Use the Windows Explorer or the Run command 
from the Windows Start Menu to launch setup.exe in the 
WEGO_Log folder on the CDROM or the setup.exe file 
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downloaded from our website. InstallShield will install the 
software in an appropriate folder under Program Files. 

Once InstallShield has completed the 
installation, WEGO Log will appear on the Windows 
Start Menu. You can then launch it just as you would 
any other Windows program.  

WEGO Log requires the Monospace 821 BT 
fixed pitch printer font in order to properly align 
columns when printing. The Monospace 821 BT font is 
included in the distribution media and automatically 
copied to your Windows Fonts folder during 
installation. A backup copy is also placed in the 
program folder. If you accidentally delete this font, use 
the Install New Font command from the Fonts folder 
File menu. The filename associated with Monospace 
821 BT is monos.ttf. 

WEGO CONNECTION  
New WEGO III and WEGO IV 

The new WEGO III and WEGO IV units connect 
to your PC by means of a USB interface. A USB cable 
is supplied with the unit. Turn on power to the WEGO 
unit. We recommend that you do not run the engine 
while you are downloading data. 

WEGO II 
Use an extension cable to connect the WEGO II 

to a serial port on your laptop PC or USB adapter. Turn 
on power to the WEGO unit. We recommend that you 
do not run the engine while you are downloading data. 

COM1 is used as the default port. If you 
connected the WEGO II to a different COM port, use 
the Port Setup command on the Communications 
menu. 

WEGO SETUP  
Prior to using the WEGO, you must set up the 

data logging parameters. Use the Edit WEGO 
Parameters command from the Edit menu. A dialog 
box will appear as shown in Figure 2. You can set the 
data logging interval and RPM pulses per revolution 
and additional parameters for newer WEGO units. 

The WEGO data buffer stores the last 8000 
data points. If you set the data logging interval to 0.50 
seconds, the unit will log over one hour of data. Data 
logging intervals of 0.2-1.0 seconds are suitable for on-
road tests; a shorter interval of 0.10 seconds is 
recommended for dyno tuning. You can clear the data 
within the WEGO by using the Clear WEGO Data 
Buffer command from the Communications menu. If 
you change the data logging interval, you should also 
clear the WEGO data buffer. 

Figure 2 – WEGO Setup 

 
If you are logging engine RPM, you must set the 

correct value for RPM pulses per revolution (PPR). 
Some general guidelines follow, based on what type of 
signal you have connected to the WEGO brown wire: 

Tach signal. In most cases PPR= N/2 where N is 
the number of cylinders. For example a V-twin 
motorcycle engine would require PPR=1and a V8 
automotive engine would require PPR=4 

Harley-Davidson dual fire ignition with 
connection to Coil- terminal. Use PPR=1 

Harley-Davidson single fire ignition with 
connection to either Coil- terminal. Use PPR=0.5 

Distributor type ignition with connection to Coil- 
terminal. Same as for a tach signal. Use PPR= N/2 
where N is the number of cylinders. 

Wasted spark coil pack (distributorless system) 
with connection to Coil- terminal. Use PPR=1. 

Coil on plug (no wasted spark) with connection to 
Coil- terminal. Use PPR=0.5 

Capacitive Discharge (CD) ignition using tach 
adapter. For one cylinder engines, use PPR=1 

RPM Debounce  – RPM signal filtering in 
milliseconds (msec). Use the default value of 0.50 
msec for most applications. Ford 4.6L modular V8 
engines will require a value of 3.5 msec. Suzuki 
Hayabusa models will require a value of 3.0 msec. 
If the RPM trace appears noisy, try a higher RPM 
debounce value. The RPM debounce parameter 
is only supported on WEGO II units with 
firmware revision 4.0 and higher (and on all 
WEGO III and WEGO IV units). The WEGO 
firmware revision is reported as part of the 
firmware ID whenever you upload to the WEGO. 
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If you have an older WEGO II unit, it can be 
upgraded to the latest firmware revision. 
Please contact our tech support for details. 

WEGO III and WEGO IV Only 
These units support an additional parameter 

related to the LED display: 

Minimum LED Brightness - This parameter sets 
the minimum LED brightness under low light (night) 
conditions. A value of 5% is reasonable for most 
applications. 100% represents maximum brightness. 

After you have entered the correct parameters, 
you must upload them to the WEGO unit. Please note 
that clicking on Restore Defaults only displays default 
values and does not affect the WEGO unless you then 
upload the restored values.   

Please note that the WEGO only logs data when 
the heater element in the sensor has warmed up to 
normal operating temperature. If you use WEGO Log 
to communicate with the WEGO (i.e. upload 
parameters or download data), data logging stops. The 
display on new WEGO III and WEGO IV units will also 
show "PC." You must cycle power to the WEGO off 
and on again before data logging will resume. 

DATA LOGGING CHART DISPLAY 
Data logged by the WEGO unit is displayed on a 

chart recorder type screen. Data logged by the WEGO 
unit must be downloaded before it can be displayed, by 
using the Download Data From WEGO command on 
the Communications menu. Once data has been 
downloaded, it is automatically displayed. The last 
data logged will appear at the right end of the 
chart.  You can save this data by using the Save File 
command from the File menu. You can display a 
previously saved data file by first using the Open File 
command on the File menu. Note that WEGO data files 
use a .log extension. You should create a separate 
folder to store these files.  

You have a range of capabilities for analyzing 
downloaded data displayed in the chart recorder 
format. You can select two parameters for display. 
Trace 1 is displayed in red with its Y axis legends on 
the left side of the chart. Trace 2 is displayed in green 
with its Y axis legends on the right side of the chart. 

The X axis is always elapsed time. You can 
select from one of four time scales. You can use the 
scroll bar to move the chart display window in terms of 
elapsed time. If you hold the left mouse button down 
within the chart area, a cursor line appears. The exact 
values of the parameters displayed on trace 1 and 

trace 2 and the elapsed time appear in windows above 
the chart. 

If you want to analyze the elapsed time between 
two events, you can move the cursor to the first event 
and then click on the Reset Time Display button. You 
can print the displayed chart to any Windows printer by 
clicking on the Print button (a color inkjet printer is 
recommended for best results).  

Data parameters include: 

RPM – engine crankshaft RPM 

AFR – air/fuel ratio (10:1 to 20:1 for gasoline)  

ANALOG INPUT – analog signal input that can 
be scaled and displayed in user selected units 
(as explained further on). 

You can use the Maximum RPM command from 
the Edit menu to change the maximum RPM value 
displayed on the chart. 

Additional data is displayed at the lower right 
side of the screen. This data includes: 

Diagnostic Code – normally blank unless a 
diagnostic code is set. Diagnostic codes include 
battery low, battery high, sensor open, sensor 
short, and over temperature (WEGO III and 
WEGO IV only). Over temperature means that 
the WEGO unit (not the sensor) has become too 
hot. 

Log Interval – the actual data logging interval in 
seconds 

The data logging interval is displayed at the 
lower right side of the screen. The WEGO data buffer 
stores the last 8000 samples. You can clear the data 
within the WEGO by using the Clear WEGO Data 
Buffer command from the Communications menu. If 
you change the data logging interval, you should also 
clear the WEGO data buffer. 

Please note that the WEGO only logs data when 
the heater element in the sensor has warmed up to 
normal operating temperature. If you use WEGO Log 
to communicate with the WEGO (i.e. upload 
parameters or download data), data logging stops. The 
display on new WEGO III and WEGO IV units will also 
show "PC." You must cycle power to the WEGO off 
and on again before data logging will resume. 
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Figure 3 – Data Logging Chart Display 

 
 

ANALOG INPUT SCALING 
When a chart display is active, you can use the 

Analog Input Scaling command on the Edit menu to 
setup the scaling and units display for the analog input.  

In general, you will enter the minimum and 
maximum input voltages and corresponding scaled 
values displayed on the chart along with the desired 
chart legend. The minimum and maximum voltages 
must be in the range of 0.0-5.0 volts. The scaled 
values must be in the range of 0-10,000. Once 
entered, analog input scaling values are saved with the 
data. Clicking on Restore Defaults causes the program 
to revert to direct 0.0-5.0 volt display on the chart.    

Figure 4 shows settings for a typical throttle 
position sensor (TPS), with 0.4 volts corresponding to 
0% and 4.5 volts corresponding to 100%. 

Figures 5 and 6 show settings for standard 
GM/Delphi 1 bar and 2 bar manifold pressure (MAP) 
sensors. Most GM vehicles and all Harley-Davidson® 
motorcycles with Twin-Cam 88® engines use GM 1 bar 
type MAP sensors. GM 2 bar MAP sensors are often 
used with aftermarket engine controls for 
turbo/supercharger applications. 



 

 
Daytona Sensors LLC, 933 Beville Road, Suite 101-I, S. Daytona, FL 32119                                      WEGO Log 
(386) 322-7390   www.daytona-sensors.com               8/2007 

 Page 6 

Figure 4 – Input Scaling for Typical TPS 

 
Figure 5 – Input Scaling for GM 1 Bar MAP 

 
Figure 6 – Input Scaling for GM 2 Bar MAP 

 
 

For other types of sensors, we suggest that you 
check the sensor output waveform with a scope meter. 
Verify that the sensor output is an analog voltage 
within the 0.0-5.0 volt range. Some Ford MAP sensors 
and GM mass airflow (MAF) sensors use a frequency 
output that is not compatible with the WEGO analog 
input. Once you verify that the sensor has an analog 
output, you still have to determine the output scaling. 
You may find this information in the service manual or 
you may have to do some reverse engineering with a 
scan tool. 

FUEL TYPE 
When a chart display is active, you can use the 

Fuel Type command on the Edit menu to setup the 
scaling of AFR values for either gasoline or methanol 
fuel. All WEGO units will log data correctly for either 
gasoline or methanol fuel, however, only special 
WEGO "M" units will show the correct methanol AFR 
values on the display.   

The program initially defaults to gasoline fuel, 
but remembers the type of fuel last selected. 

IMPORTING DATA INTO EXCEL 
Data files saved from WEGO Log are in comma 

delimited ASCII format. You can easily import a data 
file into other programs such as Microsoft Excel for 
further analysis. You can also view data files with a text 
editor such as Windows WordPad. To import a data file 
into Excel: 

1. Start Excel. In the File Open dialog box, select 
Files of type: All Files (*.*). Then browse for the 
data file. 

2. The Text Import Wizard appears. For step 1, select 
delimited file type. For step 2, select comma 
delimiter. For step 3, select general column data 
format. Then click on Finish. 

3. You can then format the data and save the 
spreadsheet as an Excel file. 

AFR data is saved as gasoline AFR values 
regardless of fuel type setting. To convert to methanol 
AFR values, use the formula: 

 AFR Methanol = .4354 x Gasoline AFR 

TROUBLESHOOTING FLOWCHART 
Follow the troubleshooting flowchart shown on 

the next page. Experience has shown that most 
communication problems are user error or PC 
compatibility issues.
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Troubleshooting Flowchart 
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